Server Outage

Incident Report for VHS Technology

Resolved

This incident has been resolved.
Posted Apr 30, 2026 - 11:58 PDT

Investigating

Due to Xfinity network maintance, VHSTech servers are currently experiencing downtime. We hope to resolve the issue as soon as possible, and we are sorry for the inconvenience.
-VHSTech Dev Team
Posted Apr 30, 2026 - 09:34 PDT
This incident affected: VHSTech Servers, Website, Games, Messaging, and Authentication.